Introdução à função SE do Excel

De forma bem resumida, a função SE do Excel realiza uma comparação lógica entre dois valores e executa uma ação de acordo com o resultado.

A função SE é muito versátil e possibilita sua utilização em diferentes situações, desde ambientes corporativos a educacionais ela pode ser utilizada sem qualquer problema.

Ela pode ser utilizada em sua forma simples até a mais complexa que é quando ela é associada a outra função.

Isso mesmo, ela pode ser utilizada com outras funções e não se limita a apenas uma por vez. A união da função SE pode ocorrer com duas, três ou quantas outras funções forem necessárias.

Ou seja, não há limite para a sua utilização.

Se o que deseja é fazer uma comparação a fim de saber a resposta entre duas possibilidades existentes, certamente a função SE Excel pode ser usada. Resumindo, quando se trata de uma condição esta é a função certa.

Achou interessante a função SE Excel? Então vamos conhecer um pouco mais sobre ela, ver alguns exemplos de sua aplicação, saber se há a união da função SE com outras e muito mais!

Tabela de Conteúdo

Função SE Excel: o que é?

No Microsoft Excel existem inúmeras funções que podem ser utilizadas para os mais variados cálculos. Uma dessas funções é a função SE.

Basicamente, ela é utilizada para retornar valores lógicos de um teste, ou seja, ela verifica se ele possui verdadeiro ou falso e a partir daí tomará uma decisão.

Para ficar mais claro: a partir de um teste lógico determinada ação será tomada se o resultado for verdadeiro; caso seja falso, outra ação será realizada.

A função SE realiza uma comparação entre um valor que é dado pelo usuário e aquilo que se espera que seja.

Mas como isso é útil? A partir dessa comparação e do resultado obtido, uma decisão pode ser tomada com mais segurança.

É por esse motivo que a função SE Excel somente apresenta dois resultados. Um deles é retornado quando o resultado da comparação é verdadeiro e o outro quando é falso.

Como é possível perceber, esta é uma função que proporciona diversas funcionalidades muito interessantes e úteis.

O melhor é que não é preciso digitá-la inúmeras vezes, pois basta automatizar o preenchimento a partir daquele raciocínio inicial apontando na fórmula.

Isso permite que na planilha sejam criados raciocínios lógicos que irão facilitar, e muito, a análise dos dados.

Quando a função condicional SE pode ser utilizada?

Não existe uma ocasião específica ou finalidade para a sua utilização, afinal, o intuito de utilizar a função SE Excel é fazer uma análise de uma condição para que determinado resultado seja obtido.

Por exemplo, saber a quantidade de alunos que foram aprovados e reprovados em uma disciplina ou professor.

Esta função necessita que os argumentos sejam preenchidos. Uma forma simples de entender isso é utilizando os argumentos verdadeiros e falsos.

A condicional SE somente pode realizar uma análise e retorna um entre dois resultados possíveis. Jamais retornará às duas possibilidades ao mesmo tempo.

Um detalhe importante que não pode ser esquecido, a função SE tanto pode retornar número quanto texto.

Mas o que isso quer dizer? Ela vai funcionar perfeitamente independente do resultado que terá de retornar.

Por exemplo, para saber se um aluno foi ou não reprovado esta função fará a análise das notas e retornará o texto “aprovado” ou “reprovado”.

Poderá retornar valores numéricos também. Tudo vai depender da necessidade que você possua.

Mais detalhes da função SE

É de fundamental importância entender como fazer a função SE. Caso contrário, ela não será realmente útil e pode ser utilizada de forma equivocada.

A função SE Excel necessita que o usuário do programa adicione valores nela. Isso vai permitir que ela faça uma avaliação dos dados que se encontram dentro do intervalo de células informado.

Somente assim ela fará a avaliação e poderá retornar uma expressão que foi previamente escolhida pelo usuário.

Essa expressão será determinada a partir de dois valores: verdadeiro ou falso como já entendemos anteriormente.

Comumente há uma união da função SE com outras, como forma de complemento.

Sua fórmula é =SE(teste_lógico;[valor_se_ verdadeiro];[valor_se_falso]) onde:

  • teste_lógico – Trata-se de um argumento obrigatório desta função que mostra o que deve ser avaliado como falso ou verdadeiro.
  • valor_se_verdadeiro – É o argumento que vai descrever qual o valor ou a expressão que será retornada se o teste_lógico for verdadeiro.
  • valor_se_falso – É o argumento que vai descrever qual o valor ou a expressão que será retornada caso o teste_lógico seja falso.

Mas o que acontece se apenas o valor_se_verdadeiro for designado e o restante foi deixado em branco?

Nesse caso, se o resultado não for verdadeiro, a expressão FALSO será retornada de forma automática.

O mesmo acontece se o campo valor_se_verdadeiro não for preenchido.

Como fazer a função SE?

Para que consiga usar a função SE Excel é preciso entender como ela funciona. Ela é composta por três argumentos que são: valor SE falso, valor SE verdadeiro e teste lógico.

Mas, como assim? Teremos um teste lógico que pode ter como retorno dois valores: um para o caso do teste ser verdadeiro e outro para o caso de ser falso.

Vamos ver alguns exemplos de sua aplicação para que o entendimento seja mais fácil?

Exemplo média final

Imagine que você é um estudante e para ser aprovado ao final do ano letivo sua média final tenha valor igual ou maior que 6. Caso essa condição não seja atendida você será reprovado.

Na tabela, temos a aplicação do exemplo média final usando a função se

No caso do nosso exemplo, o teste_lógico será a análise feita na coluna e linha correspondente a nota da média anual.

  • O valor_se_verdadeiro deve retornar Aprovado se a condição for atendida;
  • e o valor_se_falso retorna Reprovado caso a condição não seja atendida.

Para fazer essa condição na função SE Excel é preciso utilizar sua fórmula que é:

=SE(teste_lógico;[valor_se_verdadeiro];[valor_se_falso]).

Mas, antes de utilizar a fórmula, é necessário que você entenda o significado de cada sinal e cada função na tabela, para facilitar, criamos uma lista abaixo:

Na tabela, temos os comandos usados dentro da função SE

Observe que cada sinal representa uma função, no exemplo da média final que estamos utilizando, usaremos a seguinte fórmula:

=SE(B1>=6;”Aprovado”;”Reprovado”)

Dessa forma, aplicando a fórmula =SE(B1>=6;”Aprovado”;”Reprovado”) o resultado final ficará:

Temos o resultado do exemplo média final usando a função se

Exemplo de filiais

Imaginemos que você tem uma empresa com filiais em 5 capitais brasileiras e deseja verificar se as metas de faturamento que foram previamente estabelecidas foram alcançadas.

Você terá que fazer uma planilha e colocar em cada coluna as informações obtidas e a meta de faturamento.

Suponhamos que as capitais eram São Paulo, Rio de Janeiro, Belo Horizonte, Salvador e Recife.

O faturamento obtido em cada uma delas, respectivamente, foi:

  • R$ 200.000,00;
  • R$ 180.000,00;
  • R$ 150.000,00;
  • R$ 170.000,00;
  • R$ 120.000,00.

Todos esses dados ficarão armazenados nas células B2, B3, B4, B5 e B6 respectivamente.

Na coluna ao lado você irá utilizar a função SE Excel para que retorne os valores “Batemos a Meta” ou “Meta não foi batida” após avaliar as células anteriores.

Suponhamos que a meta seja a mesma para todas as filiais e que ela corresponda a R$ 180.000,00.

Assim, a fórmula ficaria: =SE(C2:C6>=180000;”Batemos a Meta”;”Meta não foi batida”).

Basta digitar uma única vez a fórmula na célula, dar Enter, retornar a ela, clicar no quadradinho preto na parte inferior direita da célula e arrastar para baixo.

Isso vai preencher as demais células com o resultado da análise sem precisar repetir toda a fórmula.

Assim, teremos que a meta foi batida nas capitais de São Paulo e Rio de Janeiro. Quanto ao restante a mensagem que irá aparecer é Meta não foi batida.

Erros comumente observados ao utilizar a função SE Excel

O Microsoft Excel é um ótimo editor de planilhas e que conta com diversas funções que facilitam, e muito, a análise e cálculo de informações.

Entretanto, não é incomum que a função SE Excel seja utilizada de forma errônea.

Comumente se observa alguns erros como não colocar a sintaxe na ordem do preenchimento. Isso faz com que o resultado seja erro.

Por isso, ao preencher a sintaxe é preciso ter muita atenção e conferir se está tudo certo. Dessa forma, é possível confiar nos resultados obtidos.

Além desse erro há outro que ocorre com muita frequência: achar que dentro do espaço para o teste lógico podem ser colocados vários testes separados apenas pelo ponto e vírgula.

Por exemplo, =SE(x2<5;x5>10…).

Isso não pode ser feito, pois a função SE somente pode fazer um teste lógico que contenha valor verdadeiro ou falso.

Se quiser obter um número de respostas maior é necessário adicionar uma função SE dentro da resposta do “valorfalso”.

Como assim?

Terá de utilizar uma função SE dentro de outra função SE. Por exemplo, =SE(B4=B5 “igual” SE(B4>B5;”maior”;”menor”)).

União da função SE do Excel com outras funções

Já vimos que a função SE é muito útil e até simples de usar. Só é preciso ter atenção para não cometer alguns erros no seu preenchimento.

Mas você sabia que ela pode ser usada com outras funções? Isso é possível e inúmeras pessoas a utilizam dessa forma por diversos motivos.

Ao unir a função SE Excel com uma, duas ou quantas funções precisar para uma mesma fórmula possibilita-se a realização de cálculos mais precisos e complexos.

Vamos ver um exemplo para compreender como funciona?

Exemplo de notas escolares

Imagine que há uma planilha com os nomes e as notas dos alunos como a descrita a seguir:

Você deseja calcular a média das duas provas e dizer se o aluno foi aprovado ou reprovado.

Nesse caso, teremos que usar a função SE com a função MÉDIA para fazer o cálculo da nota final e verificar se foi ou não aprovado. Para ser aprovado é preciso que a nota seja maior ou igual a 7.

Nossa fórmula ficará assim:

=SE(MÉDIA(B2:C3)>=7;”Aprovado”;”Reprovado”).

Vamos ver um exemplo de uma função SE dentro de outra função SE?

Exemplo recuperação escolar

Continuando com o exemplo anterior, agora é preciso fazer a verificação se o aluno vai ficar de recuperação ou não.

Para ficar em recuperação sua nota deve ser menor que 7 e maior ou igual a 5, caso a nota seja menor que 5 ele será reprovado.

Será necessário utilizar a função E para que seja feita uma comparação da média e das notas mínimas do aluno a fim de saber se foi aprovado ou está em recuperação.

Assim, a fórmula ficará da seguinte forma:

=SE(MÉDIA(B2:C3)>=7;”Aprovado”;SE(E(MÉDIA(B2:C3)>=5;MÉDIA(B2:C3)<7;”Recuperação”;”Reprovado”))).

A utilização da função SE Excel se torna um pouco mais complicada quando utilizada com mais de uma função. Nesse caso, a atenção deve ser redobrada para que não ocorra qualquer erro.

Essa é uma das maiores dificuldades encontradas principalmente por quem está iniciando no Excel.

Entretanto, quando se tem atenção e se aprende a utilizar a função SE Excel não há limites para nada. Qualquer tipo de comparação pode ser feita utilizando-se apenas uma fórmula no Microsoft Excel.

Certamente isso facilita, e muito, diversas comparações que precisam ser feitas em uma planilha.

Conclusão da Função SE

Você pode usar a função SE Excel tanto sozinha quanto em união com outras fórmulas. Por isso, vale muito a pena pesquisar como usar a função SE na sua forma mais avançada.

O Microsoft Excel é uma ferramenta muito poderosa que pode ajudar a realizar inúmeras tarefas.

O que você achou do nosso conteúdo? Conseguiu entender bem sobre a função SE? Aprendeu algo novo que vai te ajudar a desenvolver alguma tarefa?

Deixe seu comentário e caso tenha gostado do conteúdo compartilhe-o em suas redes sociais.

Comente

Seu endereço de e-mail não será publicado.